Invision Power Board forum bridge

This is a script we use on the norwegian community root.no to show the latest messages from our IPB forum in our WordPress blog template.

I already published this on my norwegian blog so I figgured I’d do the english speaking world a favor and publish it here as well in case someone was searching for “Invision Power Board forum bridge” and found the norwegian language one ;-)

The script can be downloaded here.

It will output the latest X number of messages from the forum (with forum_id’s specified in the script) in the format: <li> titled link </li> – so throw some <ul>’s around the include in your template.

Here’s how we use it: <h2><em>Latest in the forum</em></h2> <ul class="posts"> <?php include "../inc/ipb_last10.php"; ?>
</ul>

Edit the script before you upload it to your server. It should be pretty self-explanatory, but if you run into any problems just write a comment on this entry.

The script is released under a Creative Commons Attribution-Share Alike 3.0 Unported License, so enjoy.

12 Comments
  1. Hi thanks for tha beautiful script… but I tried to install it on my site but is doesnt work… I just have a blank page :/ Problem may come from the root path to the forum.. should it start like this : /customers/neo-rammstein.com/…. ?

    Any ideas otherwise? thx

  2. Hello Thomas,

    you need to find the path to the /forum/conf_global.php somehow. You can try with a relative path (like ../forum/conf_global.php etc) but if that doesn’t work you can ask your webhost for that path.

  3. well i tried to find it with a PHP script :

    and when i open it, it gives me a long path /customers/neo-rammstein.com/…. /index.php so i replace index.php with forum/conf_global.php

  4. Well, first – it depends on where your forum is installed; is it located in /forum/ ? Also, when I visit your site I find phpBB – this script is for IPB.

  5. Its located in a sidebar, i inclueded on every pages. But yesterday, a friend of mine created me a similar script. We tried to make yours working but we failed.

    His script is working… but i still have some small problems (may I ask you to have a look on it to help me to fix it? :) )

  6. ok, in the script located in the root, try setting the path like this:

    require_once ‘./forum/conf_global.php’;

    If this does not work, you need to contact your host to get the full path of the conf_global.php file and use that.

Leave a Reply to Bjørn Cancel reply